Payment Processing Issue - BlogTalkRadio
Incident Report for Voxnest
Resolved
This incident has been resolved.
Posted Sep 29, 2020 - 14:24 UTC
Update
We are continuing to monitor for any further issues.
Posted Sep 25, 2020 - 18:35 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 25, 2020 - 18:05 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 25, 2020 - 15:06 UTC
Investigating
We're investigating an issue with payments processing system on BlogTalkRadio. Is currently not possibile to subscribe to a premium plan or to upgrade your current one. Renewal of an existing monthly and yearly subscriptions is not affected.
Posted Sep 25, 2020 - 08:13 UTC
This incident affected: BlogTalkRadio - Broadcast Live Radio (Website).